Ruby threading and NTPL

Thu 15 December 2005

Filed under OS

Tags Lamer Moments

I have been monkeying with RoR and I have been getting this error every so often:

libgcc_s.so.1 must be installed for pthread_cancel to work

I haven't done much investigation, but I suspect it's because I built ruby with threads support. I recompiled and am waiting to see what happens.

update: Apparently I am totally incorrect. I don't know what layer I see this at, but i am looking into it.

update: This is a a problem with having an incorrect version of libgcc_s.so.1 in /lib. I ran 'locate libgcc_s.so.1' and found 3 copies. I copied the most recent [from my current gcc directory]. It seems to have resolved the issue.

Now, I have to tackle the clock issue. All these posts have the same time.


Comments


Up To Something © Joshua M Schmidlkofer Powered by Pelican and Twitter Bootstrap. Icons by Font Awesome and Font Awesome More